Contact us


All times are UTC - 8 hours



Post new topic Reply to topic  [ 9 posts ] 
Author Message
Offline Profile  


Joined: Mon Feb 14, 2011 10:43 am
Posts: 5
I am trying to get SAWS 3.0 Trial to work as a replacement for VSS. The main thing I wanted to use it for is the ability to deploy files to a web site just like VSS does, but for remote users.

I have imported a project with many subprojects in it and tried to deploy a single file. When I do I get the following error:

Deployed $/www.[domainname].com/images/[imagename].png to ftp://[domainname].com/httpdocs/images/[imagename].png Error unzipping file: ZIP file structure invalid.

I have set up the web deploy function in the manager a couple of different ways using both "domainname.com/httpdocs" and "ftp://domainname.com/httpdocs" as the ftp site. Neither of which seem to work.

I have looked at the xferlogs on the server, and SAWS never attempts to log onto the server.

Where is this error message coming from?


Offline Profile  


Joined: Mon Feb 14, 2011 10:43 am
Posts: 5
This is also happening with I simply go to check out a file, or get the latest version.

So it isnt just FTP and web deploy.


Offline Profile  


Joined: Tue Mar 08, 2005 12:23 am
Posts: 1315
Hi CPatterson,

The most possible cause of the issue is that your current database is corrupted.

Was the database you are using with SAWS3.0 imported from VSS? If so, did you run the VSS Analyze tool to check the integrity of your VSS database before you performed importing? If not, would you please run Analyze to check & fix your VSS database and import it into SAWS again?

Please keep me updated on the issue. For instant help, you can contact our support team at LiveChat:
http://www.dynamsoft.com/support/livehelp.aspx

Regards.

_________________
Catherine Sea
Dynamsoft Support Team
Follow us@Twitter, Facebook


Offline Profile  


Joined: Mon Feb 14, 2011 10:43 am
Posts: 5
I did run the Analyze&Fix on the VSS DB. Then I re-imported to a newly created repository.

Checking out, getting new files, etc still shows the same error.

I am going to try getting individual projects roots instead of tryign the whole thig at once. See if it it might be a specific project that is causing the error.


Offline Profile  


Joined: Tue Mar 08, 2005 12:23 am
Posts: 1315
Yes, you can try individual projects. Please keep me updated on the result.

Meanwhile, there may be some errors occurred during the import. Please check the import log in the installation folder of SourceAnywhere Standalone Server.

You can also send the log file to sawstd@dynamsoft.com and our team will help you check it.

Regards,

_________________
Catherine Sea
Dynamsoft Support Team
Follow us@Twitter, Facebook


Offline Profile  


Joined: Mon Feb 14, 2011 10:43 am
Posts: 5
Forgot to report on this. I ran the analyze on the original VSS DB, and then re-imported the files.

This did fix my problem.

Thanks for your help.


Offline Profile  


Joined: Tue Mar 08, 2005 12:23 am
Posts: 1315
Thanks for the update. I'm glad to hear that the issue has been solved. :)

_________________
Catherine Sea
Dynamsoft Support Team
Follow us@Twitter, Facebook


Offline Profile  


Joined: Tue Mar 08, 2005 12:23 am
Posts: 1315
Our developers are looking into this issue. I'll get back to you as soon as I receive any suggestions from them.

Thanks for your patience.

_________________
Catherine Sea
Dynamsoft Support Team
Follow us@Twitter, Facebook


Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 9 posts ]  Moderators: Robert, Catherine


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
cron
Copyright © 2016 Dynamsoft | All Rights Reserved
dynamic designed by Dynamsoft team