Contact us


All times are UTC - 8 hours



Post new topic Reply to topic  [ 2 posts ] 
Author Message
Offline Profile  


Joined: Fri Sep 12, 2014 8:01 am
Posts: 1
SAW Plug-in 3.01 fails during installation on Eclipse 4.4. Is the plug-in compatible with 4.4, or is there something else I need to do to install the plug-in? The following is the error log:

Code:
!ENTRY com.android.ide.eclipse.adt 1 0 2014-09-10 11:10:09.123
!MESSAGE No valid Android XML Editor Delegate found for file /Measure Mobile/build.xml [Res null, type null]

!ENTRY org.eclipse.equinox.p2.publisher.eclipse 4 0 2014-09-10 11:11:34.695
!MESSAGE Unable to acquire PluginConverter service during generation for: C:\Program Files (x86)\Eclipse\plugins\com.dynamsoft.sawhplugin_3.0.1.

!ENTRY org.eclipse.equinox.p2.touchpoint.eclipse 4 0 2014-09-10 11:11:34.704
!MESSAGE The bundle manifest could not be read: C:\Program Files (x86)\Eclipse\plugins\com.dynamsoft.sawhplugin_3.0.1

!ENTRY org.eclipse.equinox.p2.engine 4 4 2014-09-10 11:11:34.719
!MESSAGE An error occurred while installing the items
!SUBENTRY 1 org.eclipse.equinox.p2.engine 4 0 2014-09-10 11:11:34.719
!MESSAGE session context was:(profile=epp.package.standard, phase=org.eclipse.equinox.internal.p2.engine.phases.Install, operand=null --> [R]com.dynamsoft.sawhplugin 3.0.1, action=).
!SUBENTRY 1 org.eclipse.equinox.p2.touchpoint.eclipse 4 0 2014-09-10 11:11:34.719
!MESSAGE Failed to prepare partial IU: [R]com.dynamsoft.sawhplugin 3.0.1.
!SESSION 2014-09-10 11:19:36.648 -----------------------------------------------
eclipse.buildId=4.4.0.I20140606-1215
java.version=1.7.0_25
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
Framework arguments:  -product org.eclipse.epp.package.standard.product
Command-line arguments:  -os win32 -ws win32 -arch x86 -product org.eclipse.epp.package.standard.product

!ENTRY org.eclipse.egit.ui 2 0 2014-09-10 11:19:46.837
!MESSAGE Warning: EGit couldn't detect the installation path "gitPrefix" of native Git. Hence EGit can't respect system level
Git settings which might be configured in ${gitPrefix}/etc/gitconfig under the native Git installation directory.
The most important of these settings is core.autocrlf. Git for Windows by default sets this parameter to true in
this system level configuration. The Git installation location can be configured on the
Team > Git > Configuration preference page's 'System Settings' tab.
This warning can be switched off on the Team > Git > Confirmations and Warnings preference page.

!ENTRY org.eclipse.egit.ui 2 0 2014-09-10 11:19:46.846
!MESSAGE Warning: The environment variable HOME is not set. The following directory will be used to store the Git
user global configuration and to define the default location to store repositories: 'C:\Users\Thomas Han'. If this is
not correct please set the HOME environment variable and restart Eclipse. Otherwise Git for Windows and
EGit might behave differently since they see different configuration options.
This warning can be switched off on the Team > Git > Confirmations and Warnings preference page.

!ENTRY org.eclipse.team.core 4 0 2014-09-10 11:19:56.035
!MESSAGE Could not instantiate provider com.dynamsoft.shplugin.core.SAWSPluginProvider for project Measure Mobile.
!STACK 1
org.eclipse.team.core.TeamException: Could not instantiate provider com.dynamsoft.shplugin.core.SAWSPluginProvider for project Measure Mobile.
   at org.eclipse.team.core.RepositoryProvider.mapNewProvider(RepositoryProvider.java:165)
   at org.eclipse.team.core.RepositoryProvider.mapExistingProvider(RepositoryProvider.java:235)
   at org.eclipse.team.core.RepositoryProvider.getProvider(RepositoryProvider.java:507)
   at org.eclipse.egit.core.project.RepositoryMapping.getMapping(RepositoryMapping.java:264)
   at org.eclipse.egit.core.Activator$AutoShareProjects.visitConnect(Activator.java:311)
   at org.eclipse.egit.core.Activator$AutoShareProjects.access$0(Activator.java:298)
   at org.eclipse.egit.core.Activator$AutoShareProjects$1.visit(Activator.java:280)
   at org.eclipse.core.internal.events.ResourceDelta.accept(ResourceDelta.java:69)
   at org.eclipse.core.internal.events.ResourceDelta.accept(ResourceDelta.java:80)
   at org.eclipse.core.internal.events.ResourceDelta.accept(ResourceDelta.java:49)
   at org.eclipse.egit.core.Activator$AutoShareProjects.resourceChanged(Activator.java:277)
   at org.eclipse.core.internal.events.NotificationManager$1.run(NotificationManager.java:291)
   at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
   at org.eclipse.core.internal.events.NotificationManager.notify(NotificationManager.java:285)
   at org.eclipse.core.internal.events.NotificationManager.broadcastChanges(NotificationManager.java:149)
   at org.eclipse.core.internal.resources.Workspace.broadcastPostChange(Workspace.java:378)
   at org.eclipse.core.internal.resources.Workspace.endOperation(Workspace.java:1498)
   at org.eclipse.core.internal.resources.InternalWorkspaceJob.run(InternalWorkspaceJob.java:45)
   at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)
!SUBENTRY 1 org.eclipse.team.core 4 0 2014-09-10 11:19:56.036
!MESSAGE Could not instantiate provider com.dynamsoft.shplugin.core.SAWSPluginProvider for project Measure Mobile.
!SESSION 2014-09-11 18:39:08.130 -----------------------------------------------
eclipse.buildId=4.4.0.I20140606-1215
java.version=1.7.0_25
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
Framework arguments:  -product org.eclipse.epp.package.standard.product
Command-line arguments:  -os win32 -ws win32 -arch x86 -product org.eclipse.epp.package.standard.product

!ENTRY org.eclipse.team.core 4 0 2014-09-11 18:39:36.896
!MESSAGE Could not instantiate provider com.dynamsoft.shplugin.core.SAWSPluginProvider for project Measure Mobile.
!STACK 1
org.eclipse.team.core.TeamException: Could not instantiate provider com.dynamsoft.shplugin.core.SAWSPluginProvider for project Measure Mobile.
   at org.eclipse.team.core.RepositoryProvider.mapNewProvider(RepositoryProvider.java:165)
   at org.eclipse.team.core.RepositoryProvider.mapExistingProvider(RepositoryProvider.java:235)
   at org.eclipse.team.core.RepositoryProvider.getProvider(RepositoryProvider.java:507)
   at org.eclipse.egit.core.project.RepositoryMapping.getMapping(RepositoryMapping.java:264)
   at org.eclipse.egit.ui.Activator$ResourceRefreshJob.triggerRefresh(Activator.java:404)
   at org.eclipse.egit.ui.Activator$2.windowActivated(Activator.java:267)
   at org.eclipse.ui.internal.Workbench$11.run(Workbench.java:1045)
   at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
   at org.eclipse.ui.internal.Workbench.fireWindowActivated(Workbench.java:1042)
   at org.eclipse.ui.internal.WorkbenchWindow$14.shellActivated(WorkbenchWindow.java:2272)
   at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:88)
   at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
   at org.eclipse.swt.widgets.Display.sendEvent(Display.java:4353)
   at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1061)
   at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1085)
   at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1070)
   at org.eclipse.swt.widgets.Decorations.WM_ACTIVATE(Decorations.java:1666)
   at org.eclipse.swt.widgets.Shell.WM_ACTIVATE(Shell.java:2151)
   at org.eclipse.swt.widgets.Control.windowProc(Control.java:4607)
   at org.eclipse.swt.widgets.Canvas.windowProc(Canvas.java:339)
   at org.eclipse.swt.widgets.Decorations.windowProc(Decorations.java:1626)
   at org.eclipse.swt.widgets.Shell.windowProc(Shell.java:2075)
   at org.eclipse.swt.widgets.Display.windowProc(Display.java:5023)
   at org.eclipse.swt.internal.win32.OS.BringWindowToTop(Native Method)
   at org.eclipse.swt.widgets.Decorations.bringToTop(Decorations.java:230)
   at org.eclipse.swt.widgets.Shell.open(Shell.java:1217)
   at org.eclipse.e4.ui.workbench.renderers.swt.WBWRenderer.postProcess(WBWRenderer.java:745)
   at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.safeCreateGui(PartRenderingEngine.java:678)
   at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.safeCreateGui(PartRenderingEngine.java:766)
   at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.access$2(PartRenderingEngine.java:737)
   at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$7.run(PartRenderingEngine.java:731)
   at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
   at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.createGui(PartRenderingEngine.java:715)
   at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$9.run(PartRenderingEngine.java:1078)
   at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
   at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1032)
   at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:148)
   at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:636)
   at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
   at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:579)
   at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:150)
   at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:135)
   at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
   at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
   at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
   at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:382)
   at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:236)
   at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
   at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
   at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
   at java.lang.reflect.Method.invoke(Method.java:606)
   at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:648)
   at org.eclipse.equinox.launcher.Main.basicRun(Main.java:603)
   at org.eclipse.equinox.launcher.Main.run(Main.java:1465)
!SUBENTRY 1 org.eclipse.team.core 4 0 2014-09-11 18:39:36.914
!MESSAGE Could not instantiate provider com.dynamsoft.shplugin.core.SAWSPluginProvider for project Measure Mobile.

!ENTRY org.eclipse.egit.ui 2 0 2014-09-11 18:39:38.064
!MESSAGE Warning: EGit couldn't detect the installation path "gitPrefix" of native Git. Hence EGit can't respect system level
Git settings which might be configured in ${gitPrefix}/etc/gitconfig under the native Git installation directory.
The most important of these settings is core.autocrlf. Git for Windows by default sets this parameter to true in
this system level configuration. The Git installation location can be configured on the
Team > Git > Configuration preference page's 'System Settings' tab.
This warning can be switched off on the Team > Git > Confirmations and Warnings preference page.

!ENTRY org.eclipse.egit.ui 2 0 2014-09-11 18:39:38.102
!MESSAGE Warning: The environment variable HOME is not set. The following directory will be used to store the Git
user global configuration and to define the default location to store repositories: 'C:\Users\Thomas Han'. If this is
not correct please set the HOME environment variable and restart Eclipse. Otherwise Git for Windows and
EGit might behave differently since they see different configuration options.
This warning can be switched off on the Team > Git > Confirmations and Warnings preference page.

!ENTRY org.eclipse.equinox.p2.publisher.eclipse 4 0 2014-09-12 11:59:01.215
!MESSAGE Unable to acquire PluginConverter service during generation for: C:\Program Files (x86)\Eclipse\plugins\com.dynamsoft.sawhplugin_3.0.1.

!ENTRY org.eclipse.equinox.p2.touchpoint.eclipse 4 0 2014-09-12 11:59:01.240
!MESSAGE The bundle manifest could not be read: C:\Program Files (x86)\Eclipse\plugins\com.dynamsoft.sawhplugin_3.0.1

!ENTRY org.eclipse.equinox.p2.engine 4 4 2014-09-12 11:59:01.269
!MESSAGE An error occurred while installing the items
!SUBENTRY 1 org.eclipse.equinox.p2.engine 4 0 2014-09-12 11:59:01.269
!MESSAGE session context was:(profile=epp.package.standard, phase=org.eclipse.equinox.internal.p2.engine.phases.Install, operand=null --> [R]com.dynamsoft.sawhplugin 3.0.1, action=).
!SUBENTRY 1 org.eclipse.equinox.p2.touchpoint.eclipse 4 0 2014-09-12 11:59:01.269
!MESSAGE Failed to prepare partial IU: [R]com.dynamsoft.sawhplugin 3.0.1.


Offline Profile  


Joined: Tue Mar 08, 2005 12:23 am
Posts: 1315
Hi Han,

I'm afraid Eclipse 4.4 is not supported at the moment. Please try 3.x for source control integration.

Please let me know if I can be of any further assistance.

_________________
Catherine Sea
Dynamsoft Support Team
Follow us@Twitter, Facebook


Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ]  Moderators: Robert, Catherine


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
cron
Copyright © 2016 Dynamsoft | All Rights Reserved
dynamic designed by Dynamsoft team