Contact us


All times are UTC - 8 hours



Post new topic Reply to topic  [ 6 posts ] 
Author Message
Offline Profile  


Joined: Fri Dec 11, 2009 2:11 am
Posts: 3
Hello.
I'm trying to use SCM Anywhere Hosted 2.1 Plug-in for CruiseControl.NET with CruiseControl.Net v1.5.0.6237 but every time i get an error "Could not load file or assembly %path%\ccnet.SCMH.plugin.dll"
ccnet.config file looks like in the example from your site
Code:
<cruisecontrol>
  <project name="ccnet.SCMH.plugin">
    <sourcecontrol type="SCMH" autoGetSource="true" applyLabel="true">
      <organizationID>300464</organizationID>
      <ssl>false</ssl>
      <teamProjectName>default</teamProjectName>
      <serverFolder>$/ccnetTest</serverFolder>
      <username>dynamsoft1</username>
      <password>dynamsoft1</password>
      <workingDirectory>D:\ccnetTest</workingDirectory>
    </sourcecontrol>
  </project>
</cruisecontrol>

And files SCMH.Core.dll, ccnet.SCMH.plugin.dll, SCMHSDK.dll are definitely in the server directory of ccnet.
Also, i'm using Win7 x64.

Am i doing something wrong, or is there any solution to this?

Thanks.


Offline Profile  


Joined: Tue Mar 08, 2005 12:23 am
Posts: 1315
Hi,

To use SCM Anywhere Hosted CruiseControl.NET on Window 7 64-bit , please follow the steps below:

1. Install Microsoft .NET Framework SDK v2.0 (64bit). Here is the download link:
http://www.microsoft.com/downloads/deta ... laylang=en

2. Locate to the installation directory of Microsoft .NET Framework SDK v2.0 and run the following command:
C:\Program Files\Microsoft.NET\SDK\v2.0 64bit> corflags /32bit+ "C:\CruiseControl.NET-(version number)\server\ccnet.exe"

3. Run ccnet.exe.

Please keep me updated on this issue.

_________________
Catherine Sea
Dynamsoft Support Team
Follow us@Twitter, Facebook


Offline Profile  


Joined: Fri Dec 11, 2009 2:11 am
Posts: 3
This helped, thanks.


Offline Profile  


Joined: Tue Mar 08, 2005 12:23 am
Posts: 1315
Wonderful. :D

_________________
Catherine Sea
Dynamsoft Support Team
Follow us@Twitter, Facebook


Offline Profile  


Joined: Fri Dec 11, 2009 2:11 am
Posts: 3
Hello again. I have the same problem now with ccservice tool.
Here is a log:
Code:
Service cannot be started. System.BadImageFormatException: Could not load file or assembly 'file:///C:\CruiseControl.NET\server\ccnet.SCMH.plugin.dll' or one of its dependencies. An attempt was made to load a program with an incorrect format.
File name: 'file:///C:\CruiseControl.NET\server\ccnet.SCMH.plugin.dll'


Corflags didn't help. Any ideas?

Thanks.


Offline Profile  


Joined: Tue Mar 08, 2005 12:23 am
Posts: 1315
Hi,

We are not able to reproduce your issue on our side. To better pinpoint the cause, we'd like to have a GoToMeeting session with you. You can contact us at LiveHelp first:
www.dynamsoft.com/support/livehelp.aspx

Thanks,

_________________
Catherine Sea
Dynamsoft Support Team
Follow us@Twitter, Facebook


Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ]  Moderators: Robert, Catherine


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
cron
Copyright © 2016 Dynamsoft | All Rights Reserved
dynamic designed by Dynamsoft team